Sistemas‎ > ‎Redes‎ > ‎Mikrotik‎ > ‎

IPv6 - Configurando 6to4 no MikroTik para uma rede inválida

O ambiente de teste utiliza-do foi com um modem Velox roteado, um Router Board MikroTik RB433, um notebook e o Tunnel Broker (Hurricane Electric).

Configurações de IPs
 - Modem: 192.168.1.1
 - Mikrotik: 192.168.1.254

Primeiramente precisamos configurar o IP do Mikrotik na zona DMZ (Zona Desmilitarizada) do modem roteado. Assim todas as conexões ao ip válido do modem serão redirecionadas para o mikrotik.


Em seguida loga-se no site Tunnel Broker (tunnelbroker.net) para poder criar o túnel 6to4.



Clique no menu esquerdo em "Create Regular Tunnel" e cadastre o ip válido do modem (www.meuip.com.br)



Pronto, a configuração no lado servidor do túnel 6to4 esta criado. Agora falta o lado cliente.

Clique em "Example Configurations" e selecione "Mikrotik"

Ex.:

/interface 6to4 add comment="Hurricane Electric IPv6 Tunnel Broker" disabled=no local-address=201.58.125.113 mtu=1280 name=sit1 remote-address=209.51.161.58
/ipv6 route add comment="" disabled=no distance=1 dst-address=2000::/3 gateway=2001:470:4:818::1 scope=30 target-scope=10
/ipv6 address add address=2001:470:4:818::2/64 advertise=yes disabled=no eui-64=no interface=sit1



Agora abra o "winbox" e conecte no Mikrotik. Certifique-se que os pacotes IPv6 estão ativados indo no menu "System" -> "Packages".



Vá em "New Terminal" e execute as três linhas oferecidas pelo site Tunnel Broker.



Para fechar o túnel atrás de um NAT deve-se alterar o IP local do túnel. Para isso no menu "Interfaces" e edite o túnel "sit1", trocando o ip "Local Address" para o ip do mikrotik (192.168.1.254).



Para testar se o túnel foi fechado, localise o ip do Server IPv6 no site tunnel broker e tente fazer o ping através do mikrotik

Ex.: Server IPv6 Address: 2001:470:4:818::1/64

No mikrotik vá em "Tools" -> "Ping", preencha o ip e start. O status retornado deve ser "echo reply".



Verifique no site do Tunnel Broker qual é a sua Rede.

Ex.: Routed /64: 2001:470:5:818::/64

No mikrotik vá em "IPv6" -> "Addresses" e cadastre um ip, dentro da rede recebida, para o seu mikrotik na interface onde estarão os clientes.

Ex. 2001:470:5:818::1/64



No computador cliente verifique se o IPv6 foi configurado automaticamente. Caso não seja configurado automaticamente configure com o ip e gateway dentro da rede recebida.

Ex.:
 IP: 2001:470:5:818::2
 Mascara: 64
 Gateway: 2001:470:5:818::1



No site Tunnel Broker verifique os ips de DNS para serem colocados nos clientes e configure os dns dos clientes.

Ex.:
Anycasted IPv6 Caching Nameserver: 2001:470:20::2
Anycasted IPv4 Caching Nameserver: 74.82.42.42



Agora abra a console no cliente e tente pingar o endereço:

> ping6 ipv6.google.com



Acesse o site http://www.ipv6.br/ , verifique no topo da página se o IPv6 aparece e se o globo no lado direito da tela esta girando.




Referências:

Comments